Details

    • Type: Bug
    • Status: Accepted
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: puppet-agent 5.5.6
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Platform OS
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      I am getting the following error when installing "facter" gem on my brand new CentOS 7 machine

      facter-3.11.4 requires ruby version ~> 2.1.7, which is incompatible with the current version, ruby 2.4.4p296

      Puppet version
      5.5.6

      Ruby version
      ruby 2.4.4p296 (2018-03-28 revision 63013) [x86_64-linux]

      Facter version
      3.11.4 (commit dc7babfd0ad4523a72d3366cd4f4322add9c3b4b)

      Bundle version
      Bundler version 1.16.6

      My Installation script

      {{ rpm -Uvh https://yum.puppet.com/puppet5/puppet5-release-el-7.noarch.rpm}}
      {{ yum check-update -y }}
      {{ yum install puppet-agent -y }}
      {{ /opt/puppetlabs/puppet/bin/gem install bundle}}
      {{ /opt/puppetlabs/bin/puppet --version}}
      {{ /opt/puppetlabs/puppet/bin/ruby --version}}
      {{ /opt/puppetlabs/puppet/bin/facter --version )}}
      {{ /opt/puppetlabs/puppet/bin/bundle --version }}
      {{ cat > ./Gemfile <<EOF}}
      {{ source 'https://rubygems.org'}}
      {{ gem 'facter'}}
      {{ EOF}}
      {{ /opt/puppetlabs/puppet/bin/bundle install --gemfile=./Gemfile}}

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  yesoreyeram Sriramajeyam Sugumaran
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:

                    Zendesk Support