Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-2406

Update build_defaults.yaml to enable Debian 10 Buster amd64 for internal nightlies ship

    XMLWordPrintable

    Details

    • Template:
    • Acceptance Criteria:
      Hide

      https://github.com/puppetlabs/puppet-agent/blob/master/ext/build_defaults.yaml includes Debian 10 Buster amd64 and has a repo defined.

      Show
      https://github.com/puppetlabs/puppet-agent/blob/master/ext/build_defaults.yaml includes Debian 10 Buster amd64 and has a repo defined.
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      PR - 2019-04-03, PR - 2019-07-23, NW - 2019-08-07
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      Update either the foss_platforms or pe_platforms list in puppet-agent ext/build_defaults.yaml. Then add a repo config for the platform within the platform_repos section. This will enable shipping builds of this platform internally to builds.puppetlabs.lan so it can be used in CI.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              george.mrejea George Mrejea
              Reporter:
              geoff.nichols Geoff Nichols
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support