Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-2424

OpenSSL 1.0.2 FIPS

    XMLWordPrintable

    Details

    • Template:
    • Team:
      Platform OS
    • Sprint:
      Platform OS Kanban
    • QA Risk Assessment:
      Needs Assessment

      Description

      As we move to support FIPS in the Puppet Agent, we must also support the FIPS-enabled version of OpenSSL on the operating systems and devices.  We've moved to support OpenSSL 1.1 which is the current version.  The FIPS version is 1.0.2 which customers must use.  This is being raised by government customers on 2018.x and 2019.x.  There is no work around for other versions of OpenSSL. 

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            bill.diamond Bill Diamond
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support