Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-2985

Debian puppet-agent package lacks ruby-selinux

    XMLWordPrintable

    Details

    • Template:
    • Acceptance Criteria:
      Hide

      /opt/puppetlabs/puppet/bin/ruby -e "require 'selinux'"

      should succeed.

      Show
      /opt/puppetlabs/puppet/bin/ruby -e "require 'selinux'" should succeed.
    • Team:
      Night's Watch
    • Story Points:
      3
    • Sprint:
      NW - 2019-11-13, 2019-11-27
    • Method Found:
      Needs Assessment
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      Ruby SELinux libraries are now also provided for Debian and Ubuntu platforms
    • QA Risk Assessment:
      Needs Assessment

      Description

      The puppet-agent package for Debian lacks the selinux Ruby library. This prevents porting the puppet/selinux module to that OS.

      The selinux Ruby library is included in the EL version of the puppet-agent package:

      /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.5.0/x86_64-linux/selinux.so

      It cannot be installed afterwards as a gem, AFAIK.

      Is it possible to help make this happen without having access to the Puppetlabs build infrastructure? If so, is there a Github repos you could point me to?

        Attachments

          Activity

            People

            Assignee:
            gabriel.nagy Gabriel Nagy
            Reporter:
            tequeter Thomas Equeter
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support