Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-396

Runtime should be dynamic and not tied to a gcc version

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 1.6.0
    • Component/s: Packaging
    • Labels:
      None

      Description

      Currently the runtime component of puppet-agent is very hard-coded and not very flexible. It assumes very specific sonames and versions (all of which match GCC 4.8.2). Since we now have several targets using GCC 5.2.0 and we've elected to enable the runtime component on all Linux platforms, we need something more flexible.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              stahnma Michael Stahnke
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support