Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-400

Spike Windows / Ruby 2.3 vs Ruby 2.1 patch for Davis release

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Do
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      There are some remaining Unicode issues that require some core Ruby fixes (specifically for ENV).

      This ticket covers:

      • Evaluating the work to carry a backport of the patch from 2.3 to 2.1
      • A quick roundup of the remaining issues to see which are impacted / if the fix takes care of them
      • Test dumping out custom fact data / external fact data that is not UTF-8 ... to see what Puppet does

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ethan Ethan Brown
                Reporter:
                ethan Ethan Brown
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support