Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-474

Add deprecation warning for 32-bit agent Windows on 64-bit platforms

    XMLWordPrintable

    Details

    • Template:
    • Acceptance Criteria:
      • Deprecation warning in the MSI that identifies that the current combination (x86 agent on x64 platform) will EOL end of this year. Warning should be displayed in graphical installer and logged.
    • Team:
      Agent
    • Story Points:
      3
    • Sprint:
      AP 2016-11-16
    • Release Notes:
      Deprecation

      Description

      We are deprecating 32-bit Windows agents running on 64-bit platforms starting January 1, 2017.

      My original plan was to do this deprecation without engineering effort required before deprecation, but after talking with Ethan Brown, felt that it would be beneficial to users to have these warnings.

      The feature specification for deprecation can be found here:
      https://docs.google.com/a/puppet.com/document/d/1ageTqvy-CDNFDXIka-q-zyuGfl3rZxjThEuxrIJl_I8/edit?usp=sharing

      We need to add a deprecation warning in the MSI on install/upgrade that identifies that the current combination (x86 agent on x64 platform) will EOL end of this year.

        Attachments

          Activity

            People

            Assignee:
            glenn.sarti Glenn Sarti
            Reporter:
            kenaz Kenaz Kwa
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support