Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-542

Ruby 2.4 caveat for upgraders

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Agent
    • Story Points:
      2
    • Sprint:
      AP 2016-10-05, AP 2016-09-21
    • Release Notes:
      New Feature
    • Release Notes Summary:
      Hide
      Caveat for Ruby 2.4

      Reinstallation of user-installed Puppet Agent gems may be required after upgrade to Puppet Agent 5.0.
      * Due to Ruby ABI changes between Ruby 2.1 and 2.4, user-installed Puppet Agent gems (Ruby gems installed using Puppet Agent's gem binary) may require re-installation following upgrade to Puppet Agent 5.0.
      * This caveat affects gems that were installed in Puppet Agent’s gem path (using `/opt/puppetlabs/puppet/bin/gem install $gem_foo` or using the `puppet_gem` provider).
      Show
      Caveat for Ruby 2.4 Reinstallation of user-installed Puppet Agent gems may be required after upgrade to Puppet Agent 5.0. * Due to Ruby ABI changes between Ruby 2.1 and 2.4, user-installed Puppet Agent gems (Ruby gems installed using Puppet Agent's gem binary) may require re-installation following upgrade to Puppet Agent 5.0. * This caveat affects gems that were installed in Puppet Agent’s gem path (using `/opt/puppetlabs/puppet/bin/gem install $gem_foo` or using the `puppet_gem` provider).

      Attachments

        Issue Links

          Activity

            People

            Assignee:
            eric.sorenson Eric Sorenson
            Reporter:
            geoff.nichols Geoff Nichols
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support