Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-574

Update vendored win32-xxxx gems in puppet-agent

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Do
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None

      Description

      As part of the investigation into PUP-6445 it was found that the vendored gems in puppet-agent are lagging behind what we test on etc. for the puppet gem.

      example locations to update;
      https://github.com/puppetlabs/puppet-win32-ruby/tree/2.1.9.0-x64/ruby/lib/ruby/gems/2.1.0/gems

      https://github.com/puppetlabs/puppet-agent/tree/master/configs/components

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                glenn.sarti Glenn Sarti
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support