Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-621

Puppet Agent >= 1.9.0 should conflict with puppetserver < 2.7.2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 1.9.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Should not be able to install puppet-agent 1.9.0 with versions of puppetserver < 2.7.2.

      Show
      Should not be able to install puppet-agent 1.9.0 with versions of puppetserver < 2.7.2.
    • Team:
      Agent
    • Story Points:
      2
    • Sprint:
      AP 2016-11-02, AP 2016-12-14, AP 2017-01-11
    • Release Notes:
      Known Issue
    • QA Risk Assessment:
      No Action

      Description

      We are adding some gems to the Puppetserver package that will be hard dependencies of new versions of the puppet code. The puppet-agent package that contains that new puppet code must not be allowed to be installed alongside older versions of the puppetserver package.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                branan Branan Riley
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support