Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-678

Add a conflicts to the agent 1.8.x for pe-r10k < 2.5.0

    XMLWordPrintable

    Details

    • Template:
    • Acceptance Criteria:
      Hide
      Show
      Puppet-agent 1.8.0 packages conflict with pe-r10k packages < 2.5.0 Upgrades in pe-integration happen in the correct order due to these packages conflicting (i.e. resolution of https://tickets.puppetlabs.com/browse/PE-18257 )
    • Team:
      Agent
    • Story Points:
      2
    • Sprint:
      AP 2016-11-16
    • Release Notes:
      Known Issue
    • Release Notes Summary:
      Need a note in the installation docs for PE and puppet agent that highlight this conflicts.

      Description

      pe-r10k versions less than 2.5.0 all have conflicting gems with the agent (both packages vendor the gettext gems).

      We need to add a conflicts statement to puppet-agent so the package conflicts with pe-r10k like so:

      in the puppet-agent project config:

      proj.conflicts "pe-r10k" "2.5.0"
      

      Then we need to test that the conflicts statement has worked and will actually conflict with r10k

        Attachments

          Activity

            People

            Assignee:
            maggie Maggie Dreyer
            Reporter:
            sean.mcdonald Sean McDonald
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support