Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-730

Puppet Agent should ship with a more recent Hocon gem

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: puppet-agent 1.9.0
    • Fix Version/s: puppet-agent 1.9.0
    • Component/s: Packaging
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Puppet-agent packages contain the appropriate version of Hocon gem.

      Show
      Puppet-agent packages contain the appropriate version of Hocon gem.
    • Team:
      Agent
    • Story Points:
      2
    • Sprint:
      AP 2017-01-11
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      Gem update

      Description

      Currently flanders builds contain 1.8.0 agents with version 0.9.3 of the Hocon ruby gem, we need to bump the agent version and include at least version 1.1.3 of the gem to allow parsing of Hocon configs.

      There are some additional fixes in the latest 1.2.4 which would be desirable but the impact of such a large jump have not been investigated.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              john.mccabe John McCabe
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support