Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-778

Swig generates non valid output on el5

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: puppet-agent 1.8.2
    • Fix Version/s: None
    • Component/s: Packaging
    • QA Risk Assessment:
      Needs Assessment

      Description

      When building puppet-agent's libselinux component with vanagon for el5 platform, swig (1.3.29) generates a non usable output. The file contains invalid calls (mostly because the Ruby version is newer than the expected).

      Not much experience with swig but I managed to solve the problem applying a patch after running swig. This patch change calls to RSTRING struct pointers to use StringValueLen and StringValuePtr.

      You can check the changes we made https://github.com/cernops/puppet-agent/commit/5122a3e24aeba29293ba0735d411513f0fcfd9e1.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              david.mogar David Moreno García
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Zendesk Support