Uploaded image for project: 'Puppet Agent'
  1. Puppet Agent
  2. PA-987

Remove AIX 5.3 from puppet-agent

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: puppet-agent 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      • AIX 5.3 artifacts are no longer built as part of the puppet-agent suite pipeline
      • AIX 5.3 is no longer tested in the hardware testing pipeline
    • Team:
      Agent
    • Story Points:
      1
    • Sprint:
      AP 2017-03-08
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      AIX 5.3 will no longer be supported in Puppet 5. This ticket removes it from our internal builds and testing.
    • QA Risk Assessment:
      Manual
    • QA Risk Assessment Reason:
      We should verify that AIX 5.3 components are no longer built

      Description

      AIX 5.3 will no longer be supported in Puppet Agent 5, per its Puppet EOL date on 06/30/17 (see https://puppet.com/content/platform-support-lifecycle). We need to remove it from build and test lists in puppet-agent.

      Note: there might be associated changes needed in PE.

      Also note: There are issues with the Ruby 2.3.3 build on this platform. Switching puppet-agent over to using Ruby 2.3.3 is blocked on its removal, or a fix of the errors if we cannot stop supporting this platform.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                maggie Maggie Dreyer
                QA Contact:
                Eric Delaney
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support