Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-1003

"You shall not pass!" error could be more informative

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 3.0.0
    • Component/s: None
    • Template:
    • Story Points:
      1
    • Sprint:
      PuppetDB 2015-02-25

      Description

      While entertaining, it would nice if the "You shall not pass!" error provided useful feedback.

      Something like:

      Is your master's certname listed in PuppetDB's cetificate-whitelist file? 
       
      Also, if you recently re-certed your PuppetDB node, you may need to run puppetdb ssl-setup -f and then restart PuppetDB.
      

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                russell.mull Russell Mull
                Reporter:
                zee Zee Alexander
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: