Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-1017

Node tests broken due to bug in assertion code

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 2.3.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      PuppetDB 2014-12-03

      Description

      While looking into another issue, I found two issues related to our node-query tests, specifically here: https://github.com/puppetlabs/puppetdb/blob/master/test/puppetlabs/puppetdb/http/nodes_test.clj#L65. There are tests in that namespace that actually generate incorrect SQL, I see a stacktrace in standard error, but the error isn't returned and PuppetDB is actually responding with a 200 and an empty body. The empty body causes the doseq above to be skipped, and since the response is 200, the test runs successfully, even though there was a failure and no results were returned.

      We should also look into our bad handling of this failed query. Ideally it should be returning a 4xx error, but certainly shouldn't return a 200.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                ryan.senior Ryan Senior
                Reporter:
                ryan.senior Ryan Senior
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: