Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-1212

Bug in generation of /opt/puppet/libexec/puppetdb/pe-puppetdb.env

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDB 2.2.2
    • Fix Version/s: PDB 2.2.2, PDB 2.3.0, PDB 3.0.0
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      0
    • Sprint:
      PuppetDB 2015-02-11

      Description

      If /etc/sysconfig/pe-puppetdb is missing or unreadable there will be a syntax error in the template /opt/puppet/libexec/puppetdb/pe-puppetdb.env. This will causes puppetdb process to crash or be unable to start.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  wyatt Wyatt Alt
                  Reporter:
                  kaitlin Kaitlin Carter
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: