Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-13

Add acceptance tests for wheezy (for ruby 1.9 validation)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 2.2.1
    • Component/s: QA, RE
    • Labels:
    • Template:
    • Story Points:
      3
    • Sprint:
      20140827 to 20140910, PuppetDB 2014-09-24, PuppetDB 2014-10-08, PuppetDB 2014-10-22

      Description

      Currently puppetdb acceptance runs against el5, el6, precise, lucid and squeeze. All of these platforms default to ruby 1.8, which is end of life. precise lucid and squeeze have 1.9 available, but not the default.

      If fedora 18, or wheezy, quantal or raring were added to the mix we would have some ruby 1.9 coverage at least.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  wyatt Wyatt Alt
                  Reporter:
                  matthaus Past Haus
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: