Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-1389

PuppetDB won't install alongside the puppet-agent on debian

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDB 2.3.2
    • Fix Version/s: PDB 2.3.3
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      2
    • Sprint:
      RE 2015-04-08

      Description

      Because of how debian packages work, they cannot have versioned provides. A consequence of this is that despite puppet-agent providing both puppet and puppet-common, because puppetdb requires puppet/puppet-common >= 3.5.1 the puppet-agent package cannot satisfy those dependencies, which renders the combination uninstallable.

      apt-get install puppetdb
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
       
      The following packages have unmet dependencies:
       puppetdb : Depends: puppet (>= 3.5.1)
      E: Unable to correct problems, you have held broken packages.
      

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  matthaus Past Haus
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: