Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-1469

puppetdb-terminus-2.3.3-1.el6 cannot find rubygems-json package

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 2.3.5
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      2
    • Sprint:
      PuppetDB 2015-06-03

      Description

      Trying to install puppetdb on a puppetserver and PC1 system.

      Attempting to install rubygem-json results in a package not found, but yet the puppetdb-terminus package fails due to the dependency.

      $ yum install -y rubygems ruby-sqlite3 rubygem-activerecord rubygem-json
      Loaded plugins: product-id, subscription-manager
      This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
      Setting up Install Process
      Package rubygems-1.3.7-5.el6.noarch already installed and latest version
      No package ruby-sqlite3 available.
      No package rubygem-activerecord available.
      No package rubygem-json available.
      Nothing to do
       
      ....
       
      Error: Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install puppetdb-terminus-2.3.3-1.el6' returned 1: Error: Package: puppetdb-terminus-2.3.3-1.el6.noarch (pl-puppetdb
      -2.3.3)
                 Requires: rubygem-json
       You could try using --skip-broken to work around the problem   
      

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  john.duarte John Duarte
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: