Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-2058

build from source instructions no longer valid for PDB 3+ on arch linux (if not in general)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 3.2.1
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      2
    • Sprint:
      PuppetDB 2015-11-04

      Description

      user frozengeek on IRC reported that the documented instructions for source builds will now result in the error

      [root@localhost puppetdb]# sudo LEIN_ROOT=true rake install
      rake aborted!
      Don't know how to build task 'install'
      

      on arch linux. I've confirmed this for myself, and also confirmed that things work as documented for 2.3.8, which makes me think this is some ezbake fallout. Haven't checked whether other OSes are affected yet, but I'd guess probably so.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                wyatt Wyatt Alt
                QA Contact:
                Kurt Wall
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: