Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-2910

puppetserver / puppetdb ship with empty pid file

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 4.2.0
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      Reported by Roman Mueller in EZ-84:

      After installing puppetserver or puppetdb on CentOS 6 a pid file is automatically created although the service is not being started.

      Example:

      [root@centos6 vagrant]# yum -y install puppetserver
      (...)                                                                                                                                                            
       
      Complete!
      [root@centos6 vagrant]# service puppetserver status
      puppetserver dead but pid file exists
      [root@centos6 vagrant]# cat /var/run/puppetlabs/puppetserver/puppetserver 
       
      [root@centos6 vagrant]#
      

      The pid file should not get automatically created, only the folder containing it.
      Same is happening with puppetdb.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              geoff.nichols Geoff Nichols
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support