Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-2950

Bump required postgres to 9.6

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PDB 5.0.0
    • PuppetDB
    • None
    • New Feature
    • Hide
      PuppetDB now only supports PostgreSQL 9.6 and newer. Support for versions prior to 9.6 have been retired. Users must upgrade PostgreSQL to 9.6 or newer before upgrading PuppetDB. Users should also enable the [`pg_trgm`][pg_trgm] extension, as explained [here][configure_postgres]. The official PostgreSQL repositories are recommended for packaging. See the [YUM](https://wiki.postgresql.org/wiki/YUM_Installation) instructions or the [Apt](https://wiki.postgresql.org/wiki/Apt) instructions for more details.
      Show
      PuppetDB now only supports PostgreSQL 9.6 and newer. Support for versions prior to 9.6 have been retired. Users must upgrade PostgreSQL to 9.6 or newer before upgrading PuppetDB. Users should also enable the [`pg_trgm`][pg_trgm] extension, as explained [here][configure_postgres]. The official PostgreSQL repositories are recommended for packaging. See the [YUM]( https://wiki.postgresql.org/wiki/YUM_Installation ) instructions or the [Apt]( https://wiki.postgresql.org/wiki/Apt ) instructions for more details.

    Description

      RDS has support already, and this will allow us to use upsert as well as a number of performance improvements.

      Attachments

        Activity

          People

            russell.mull Russell Mull
            wyatt Wyatt Alt
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support