Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3064

PuppetDB chokes on enqueued reports going from 3.2.x to 4.2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDB 4.2.2
    • Fix Version/s: PDB 4.2.4
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Dumpling
    • Story Points:
      1
    • Sprint:
      FF 2016-10-19, FF 2016-11-02

      Description

      This is a bug with corrective_change being required for some events thing. The problem is somewhere in the reports command version translation code.

      2016-09-21 15:53:11,646 ERROR [o.a.a.ActiveMQMessageConsumer] ID:mbp.local-64396-1474498387723-6:1:3:1 Exception while processing message: ID:mbp.local-60682-1474498266238-8:1:21:1:91
      clojure.lang.ExceptionInfo: Value does not match schema: {:resources [{:corrective_change missing-required-key, :events [{:corrective_change missing-required-key}]} {:corrective_change missing-required-key, :events [{:corrective_change missing-required-key}]} {:corrective_change missing-required-key, :events [{:corrective_change missing-required-key}]} {:correct
      ive_change missing-required-key, :events [{:corrective_change missing-required-key}]} {:corrective_change missing-required-key, :events [{:corrective_change missing-required-key}]}]}
      

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                wyatt Wyatt Alt
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: