Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3255

Update to i18n 0.6.0 and add i18n-clj job to CI pipeline

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 4.4.0
    • Component/s: None
    • Labels:
    • QA Risk Assessment:
      Needs Assessment

      Description

      OSS and PE PuppetDB should be updated to the latest clj-i18n version, 0.5.1 and have their CI pipelines updated to include the i18n-clj template. This will allow the locale POT files to be updated automatically by CI whenever any externalized strings need to be changed based on the latest Clojure code in the projects. This avoids the need to update the files at compile time and include those changes on a per-PR basis.

        Attachments

          Activity

            People

            • Assignee:
              ryan.senior Ryan Senior
              Reporter:
              jeremy.barlow Jeremy Barlow
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support