Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3426

Docs: "Install PuppetDB from packages" page needs improvements

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDB 4.4.1
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Systems Engineering
    • Story Points:
      1
    • Sprint:
      PuppetDB 2017-04-19
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      When I did a Google search for "Install PuppetDB" I was directed to https://docs.puppet.com/puppetdb/4.4/install_from_packages.html - the page on "Installing PuppetDB from Packages".

      1) This page recommends at the top

      If you are just getting started with Puppet and don’t yet know how to assign Puppet classes to nodes, this is the guide for you.

      However, we want users to use the module, rather than installing from packages. The top of this page should recommend that users install via the module.

      2) "Step 4: Configure database: Set up a PostgreSQL server and configure PuppetDB to use it." links to https://docs.puppet.com/puppetdb/4.4/configure.html#using-postgresql, which says nothing about how to set up a PostgreSQL server or even what version to install. Instead, it says

      Before using the PostgreSQL backend, you must set up a PostgreSQL server, ensure that it will accept incoming connections, create a user for PuppetDB to use when connecting, and create a database for PuppetDB. Completely configuring PostgreSQL is beyond the scope of this guide...

      While configuring PostreSQL may be outside of the scope of the guide, at least mentioning the version number of Postgres that is required and preferably linking to some other documentation on setting Postgres up would be much more helpful than what is currently there. Maybe the "configuring puppetdb" page isn't the right place for this, but somewhere in the trail from the "Install from Packages" page would be good, since that does seem to be one of the top Google hits.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ruth Ruth Linehan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support