Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3558

Update puppetdb-termini 5 package to dep on puppet-agent >= 5

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PDB 5.0.1
    • PuppetDB
    • None
    • Data Platform
    • Deprecation
    • PuppetDB is no longer compatible with agent and server versions older than 5.0.0.
    • Needs Assessment

    Description

      Improvements have gone into Puppet 5 that obsolete processing done in the puppetdb terminus, meaning we're doing a bunch of extra work there.

      With a hard dep on puppet agent 5 we can rely on the new behavior, remove some of the processing in the terminus, with likely performance and maintainability benefits.

      For example, the `stringify_` methods in the puppetdb catalog terminus are likely no longer necessary.

      In Scope

      • Update the dependency that puppetdb-termini expresses on puppet-agent to be versioned, ie puppet-agent >= 5

      Update
      Currently, FOSS PDB specifies a dependency on puppet (<< 5.0.0-1puppetlabs1) which may mean that users can't upgrade to Puppet 5 on their FOSS PDB/MOM unless we make this change - PDB 5.0 can be installed only with Puppet Agent 4.10.x or earlier.

      Attachments

        Activity

          People

            Unassigned Unassigned
            moses Moses Mendoza
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support