Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3587

puppetlabs-puppetdb : doesn't work with puppetlabs-postgresql 5.x

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version:

      Describe your issue in as much detail as possible...

      The puppetdb module currently pins on postgresql < 5.0.0, and now that 5.0.0 is out it is incompatible. https://github.com/puppetlabs/puppetlabs-puppetdb/blob/master/metadata.json#L81

      Desired Behavior:
      Installing a 5.x series of postgresql with puppetdb works.

      Actual Behavior:
      Puppet run fails with following error:
      Error: Evaluation Error: Error while evaluating a Resource Statement, Postgresql::Server::Grant[database:GRANT puppetdb - all - puppetdb]: parameter 'port' expects an Integer value, got String at /etc/puppetlabs/code/environments/production/modules/postgresql/manifests/server/database_grant.pp:10 on node centos-7-x64

      Please take a moment and attach any relevant log output and/or manifests. This will help us immensely when troubleshooting the issue.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                hunter Hunter (Hunner) Haugen
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: