Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3743

ensure PDB 4.4.x can be run with puppetserver 5.x

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      User devicenull on freenode reports that PDB 4.4 does not run with puppetserver 5, even with a v5 terminus, due to a schema violation:

      09:21 <devicenull> clojure.lang.ExceptionInfo: Value does not match schema: {:job_id disallowed-key}
      

      We should release a fix to 4.4.x that relaxes the schema so that we have an upgrade path, since this means that currently users must upgrade puppetserver and PDB at the same time.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  wyatt Wyatt Alt
                • Votes:
                  4 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated: