Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-3971

PupetDB install fails on Ubuntu 18.04 Bionic Beaver

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: PDB 5.2.0, PDB 5.2.2
    • Fix Version/s: None
    • Component/s: PuppetDB
    • Labels:
      None
    • Template:
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Fresh install of puppet-master 5.4 on Ubuntu 18.04 LTS, try to install PuppetDB per instructions here:

      https://puppet.com/docs/puppetdb/5.2/install_from_packages.html

      Error:

      user@puppet:~$ sudo puppet resource package puppetdb ensure=latest
      {{[sudo] password for user: }}
      Error: Could not update: Execution of '/usr/bin/apt-get q -y -o DPkg::Options::=-force-confold install puppetdb' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      E: Unable to locate package puppetdb
      Error: /Package[puppetdb]/ensure: change from 'purged' to 'latest' failed: Could not update: Execution of '/usr/bin/apt-get q -y -o DPkg::Options::=-force-confold install puppetdb' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      E: Unable to locate package puppetdb
      package { 'puppetdb':
      {{ ensure => 'purged',}}
      }

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jchause Joe Hause
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support