Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-4072

HA out-of-sync after restart

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: PDB 5.2.4
    • Fix Version/s: None
    • Component/s: HA
    • Labels:
      None
    • Environment:

      PE 2018.1.3 HA with compile masters. The following things are out of the ordinary for this environment:

      • ~5500 Nodes
      • Many hundreds of events per run (~250)
      • Some resource titles over 4000 characters long
    • Template:
    • Team:
      PuppetDB
    • Method Found:
      Customer Feedback
    • CS Priority:
      Major
    • QA Risk Assessment:
      Needs Assessment

      Description

      When running in a HA setup I'm seeing strange issues after restarting PuppetDB on either the Primary or Secondary master. Both masters will run fine for many hours/days with no sync errors. However after restart they will determine that they are are a long way out-of-sync and re-sync themselves, for example after both machines bing up for 4 days, restarting the primary caused it to re-sync 10,000 reports. This causes prolonged downtime as the PuppetDB service remains in "starting" mode and cannot process requests.

      Possibly there is some difference in the way that PuppetDB does an initial as opposed to one of the subsequent syncs?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              austin.blatt Austin Blatt
              Reporter:
              dylan.ratcliffe Dylan Ratcliffe
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support