Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-4508

puppetdb-termini for puppet standalone try to connect to master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Froyo
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      While trying to implement https://puppet.com/docs/puppetdb/6.0/connect_puppet_apply.html#option-a-set-up-an-ssl-proxy-for-puppetdb I've stumbled upon a bug which seems to have been caused https://github.com/puppetlabs/puppet/commit/1360fcc4ab8af8ab0be5ec57f40c045c59feb506 (PUP-8655).

      puppet apply try to connect to the master (even though I don't have one) before sending the facts to puppetdb.

      The following line in lib/puppet/ssl/validator/default_validator.rb seems to cause the problem.

      def setup_connection(connection, ssl_host = Puppet.lookup(:ssl_host))
         

      If I remove the Puppet.lookup call on this line everything works fine.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tony.vu Tony Vu
              Reporter:
              Gregoire Grégoire Menuel
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support