Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-4709

PuppetDB 6.10 schema migration failed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: PDB 6.10.0, PDB 5.2.14
    • Fix Version/s: PDB 5.2.15, PDB 6.10.1
    • Component/s: PuppetDB
    • Labels:
      None
    • Template:
    • Agent OS:
      Ubuntu 16.04 (i386, amd64)
    • Master OS:
      Ubuntu 16.04 (amd64)
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Fixed an issue that would cause PuppetDB to fail to start on a database that had migrations from before PuppetDB 4.0.0.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Service fails to start after 6.9.1 -> 6.10.0 upgrade.

      WARNING: An illegal reflective access operation has occurred
      WARNING: Illegal reflective access by dynapath.defaults$fn__20897$fn__20898 (file:/opt/puppetlabs/server/apps/puppetdb/puppetdb.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
      WARNING: Please consider reporting this to the maintainers of dynapath.defaults$fn__20897$fn__20898
      WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
      WARNING: All illegal access operations will be denied in a future release
      The [database] classname config option has been retired and will be ignored.
      The [database] conn-keep-alive config option has been retired and will be ignored.
      The [database] log-slow-statements config option has been retired and will be ignored.
      The [database] subprotocol config option has been retired and will be ignored.
      The [read-database] classname config option has been retired and will be ignored.
      The [read-database] conn-keep-alive config option has been retired and will be ignored.
      The [read-database] log-slow-statements config option has been retired and will be ignored.
      The [read-database] subprotocol config option has been retired and will be ignored.
      The [database] classname config option has been retired and will be ignored.
      The [database] conn-keep-alive config option has been retired and will be ignored.
      The [database] log-slow-statements config option has been retired and will be ignored.
      The [database] subprotocol config option has been retired and will be ignored.
      The [read-database] classname config option has been retired and will be ignored.
      The [read-database] conn-keep-alive config option has been retired and will be ignored.
      The [read-database] log-slow-statements config option has been retired and will be ignored.
      The [read-database] subprotocol config option has been retired and will be ignored.
      Execution error (IllegalStateException) at jdk.internal.reflect.NativeConstructorAccessorImpl/newInstance0 (NativeConstructorAccessorImpl.java:-2).
      Your PuppetDB database contains a schema migration numbered 1, but this version of PuppetDB does not recognize that version.
      Full report at:
      /tmp/clojure-14479181673949144443.edn

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              rob.browning Rob Browning
              Reporter:
              iain-buclaw-sociomantic Iain Buclaw
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support