Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-847

PuppetDB 2.x is not compatible with Puppet Enterprise

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: PDB 2.2.0
    • Fix Version/s: PDB 2.2.1
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      20140827 to 20140910

      Description

      Due to the Puppet version check introduced in 40c42e3, PuppetDB 2.x doesn't work with Puppet Enterprise. This happens because it tries to use the SemVer library to assert that Puppet.version is > 3.5.1. That check doesn't work in PE because Puppet.version is a string like 3.6.2 (Puppet Enterprise 3.4.0-rc1-601-gd369ee8) rather than a real semver. It's also a redundant check, because a) the puppetdb-terminus package has a hard dependency on puppet 3.5.1, and b) the version of puppet in PE will always be compatible with the version of PuppetDB in PE.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                wyatt Wyatt Alt
                Reporter:
                ken Ken Barber
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: