Uploaded image for project: 'PuppetDB'
  1. PuppetDB
  2. PDB-868

Potential race condition causing API error in db_resilience/postgres_restart.rb

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDB 2.2.1
    • Fix Version/s: PDB 2.2.1
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      2
    • Sprint:
      PuppetDB 2014-09-24

      Description

      Saw this again in upgrade tests today (https://jenkins.puppetlabs.com/job/PuppetDB%20Acceptance%20IN%20THE%20CLOUD/43/BEAKER_CONFIG=ec2-west-ubuntu1004-64mda-64a,BEAKER_OPTIONS=postgres,PUPPETDB_INSTALL_MODE=upgrade,label=beaker-ec2/consoleFull). Upgrade from 2.2.0 to 6bcf92428b55ca8ffd147f7789a865d8a3e5441c on lucid amd64 failed with the following error:

      Errored Tests Cases:
        Test Case acceptance/tests/db_resilience/postgres_restart.rb reported: #<JSON::ParserError: A JSON text must at least contain two octets!>

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                ken Ken Barber
                Reporter:
                ken Ken Barber
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: