Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1066

Use ruby 2.4.4 with travis-ci

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.6.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      The .travis-ci.yml file is configured to use rvm 2.4.1 whereas the PDK provides ruby 2.4.4.

    • Template:
    • Acceptance Criteria:
      Hide

      The travis-ci config specifies the ruby 2.4.4 version as default.

      Show
      The travis-ci config specifies the ruby 2.4.4 version as default.
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      Stale ticket, fix was released in 1.6.1
    • QA Risk Assessment:
      Needs Assessment

      Description

      Travis is configured to use Ruby 2.4.1 but the PDK ships Ruby 2.4.4.

      Adjust Travis config to Ruby 2.4.4

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            Raffaello Thomas Mueller
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support