Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1070

PDK validate doesn't seem to honor rubocop excludes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: PDK 1.6.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 10 - 1803
      PDK - 1.6.0.0

    • Template:
    • Acceptance Criteria:
      • pdk validate should raise violations the same as a raw call to rubocop would
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      Duplicate
    • QA Risk Assessment:
      Needs Assessment

      Description

      The pdk validate command is throwing rubocop errors for files that are excluded via the rubocop.yml configuration file. Running rubocop separately finds no errors, as expected. This appears to be a bug in the PDK.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                glenn.sarti Glenn Sarti
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support