Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1086

UX: pdk build won't let me --force but lets me skip all questions

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.10.0
    • Component/s: None
    • Template:
    • Team:
      Puppet Developer Experience
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      `pdk build --force` will now print a warning to the user about incomplete module metadata and continue to build the module package rather than fail before building the package.
    • QA Risk Assessment:
      Needs Assessment

      Description

      When using the pdk build command, I can't --force the build even when I can opt out of all the questions. This seems inconsistent and not a great user experience; these questions should be either required or not required.

      The metadata page says that "source" is a required field, so maybe it should be required instead of skippable in the build interview? Or maybe we just need to explain ourselves more?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tim.sharpe Tim Sharpe
                Reporter:
                jean Jean Bond
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support