Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1208

Update lower bound of default puppet range for newly generated modules

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.8.0
    • Component/s: None
    • Template:
    • Team:
      Puppet Developer Experience
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      Adding support for data-in-modules in the pdk template requires increasing the lower bound of the puppet requirement to ">= 4.10.0". This impacts newly generated modules.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Since we merged the data-in-modules pull request and the oldest supported version of puppet has moved on, we should update the default puppet compatibility range for newly generated modules to have a lower bound of ">= 4.10".

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                jesse Jesse Scott
                Reporter:
                jesse Jesse Scott
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: