Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1277

GitLab CI Update to Puppet 6 and Remove Puppet 4

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.9.1
    • Component/s: None
    • Template:
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      This updates the gitlab-ci configuration to be on-par with the travis-ci and appveyor configurations to test and validate against the latest supported puppet versions.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Hello,

      When using PDK to generate or convert a module, the .gilab-ci.yml it creates runs tests against Puppet 4, which has reached end of life, and Puppet 5.5, but it does not run any Puppet 6 tests.

       

      Could the template for .gitlab-ci.yml please be updated to test against the appropriate versions of Ruby and Puppet?

       

      Respectfully,

      Jake

        Attachments

          Activity

            People

            • Assignee:
              bryan.jen Bryan Jen
              Reporter:
              jspain Jake Spain
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support