Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1367

Issue deprecation warning when activating a 4.x puppet version

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.14.0
    • Component/s: None
    • Template:
    • Acceptance Criteria:
      • A deprecation warning is raised to the user any time PDK activates a 4.x Puppet version.
    • Team:
      Puppet Developer Experience
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      A deprecation warning will now be displayed when users select a Puppet version < 5.0.0
    • QA Risk Assessment:
      Needs Assessment

      Description

      Since Puppet 4 went EOL in October 2018, we will eventually stop including Puppet 4 (and the accompanying Ruby 2.1.9 runtime) as part of PDK packages. While we still haven't decided exactly when we will remove those components, we should start issuing deprecation warnings as soon as possible.

      The warning should be raised any time the PDK's Puppet version resolver activates a 4.x Puppet version.

        Attachments

          Activity

            People

            Assignee:
            tim.sharpe Tim Sharpe
            Reporter:
            jesse Jesse Scott
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support