Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1433

`pdk validate ruby` fails on macOS due to incorrect permissions in rubocop-i18n gem

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDK 1.11.0, PDK 1.11.1
    • Fix Version/s: PDK 1.12.0
    • Component/s: None
    • Environment:

      Only reproduced on macOS platforms so far.

    • Template:
    • Team:
      Puppet Developer Experience
    • Method Found:
      Customer Feedback
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Resolved an issue where the `rubocop-i18n` gem included with PDK had incorrect permissions when installed on certain versions of macOS which could cause errors during `pdk validate`.
    • QA Risk Assessment:
      Needs Assessment

      Attachments

        Issue Links

          Activity

            People

            Assignee:
            jesse Jesse Scott
            Reporter:
            jesse Jesse Scott
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support