Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1495

Update `pdk new unit_test` to `pdk new test --unit`

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Normal
    • Resolution: Fixed
    • None
    • PDK 1.14.0
    • None
    • New Feature
    • `pdk new test_unit` experimental UX has been changed to the finalised `pdk new test --unit` UX
    • Needs Assessment

    Description

      Puppet design prefers using hyphens as word separators over underscores when not prevented by a technical blocker, especially in CLI designs and API designs. See puppet-nogui, here and here.

      By preferred Puppet design, the underscore word separator in pdk new unit_test is incorrect. It should be pdk new unit-test.

      Attachments

        Activity

          People

            tim.sharpe Tim Sharpe
            reid Reid Vandewiele
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support