Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1519

Add deprecation warning when PDK invoked under Ruby < 2.4

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: PDK 1.14.1
    • Component/s: None
    • Template:
    • Acceptance Criteria:
      • PDK should issue a deprecation warning when invoked under a Ruby version < 2.4.
    • Team:
      Puppet Developer Experience
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      A deprecation notice has been added to the PDK CLI to inform users using Ruby < 2.4 that support for Ruby < 2.4 will be dropped in PDK 2.0.0
    • QA Risk Assessment:
      Needs Assessment

      Description

      We should start issuing a deprecation warning if PDK is invoked under a Ruby version < 2.4, in preparation for eventually removing support for older versions of Ruby.

        Attachments

          Activity

            People

            Assignee:
            tim.sharpe Tim Sharpe
            Reporter:
            jesse Jesse Scott
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support