Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1529

Update the version of GIT in PDK

    XMLWordPrintable

Details

    • Enhancement
    • Vendored git updated to 2.24.0
    • Needs Assessment

    Description

      We have run into an issue with the version of GIT that is currently in the PDK. Our repo implementation requires that we have at a minimum version 2.16 for GIT as we need additional SSL backend features. The current version of GIT included in the PDK doesn't support our SSL backend implementation, so the PDK errors out on any test unit run, because it cannot clone neccessary repos in the fixtures file. Can the version of GIT bundled in the PDK be updated, or can the PDK be updated to use the version of git installed?

      We have this issue on a mixture of windows and mac machines. 

      Attachments

        Activity

          People

            tim.sharpe Tim Sharpe
            jlwoodman21 Justin Woodman
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support