Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-1591

PDK support for disabling legacy facts

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.18.0
    • Component/s: None
    • Template:
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      Users can now set `disable_legacy_facts` to `true` in the common section of their `.sync.yml` (see pdk-templates readme) to have `pdk validate` warn (and optionally autocorrect) use of "legacy" Facter facts in their manifests.
    • QA Risk Assessment:
      Needs Assessment

      Description

      FACT-1858 implements a way to block legacy facts so they are not sent from agent to master ( and subsequently PDB). 

       

      In order to facilitate users incorporating this opt-in benefit we should add support to PDK so users can test existing modules and ideally get new modules created with the legacy facts disabled by default.  

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tim.sharpe Tim Sharpe
              Reporter:
              nick.walker Nick Walker
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support