Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-389

Remove any legacy support hacks from template

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.5.0
    • Component/s: None
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      This removes artifacts/dependencies from the pdk-templates that were there to support Puppet versions less than 4.7.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Review the pdk-module-template and remove any pre-puppet-4.7, and ruby pre-2.1.9 support.

      -Clean up Gemfile to remove dependency pins and older cruft that was placed to support those.
      -puppet-module-gems should also be investigated to remove any pins in the dependency config that was introduced for older ruby and puppet support.

      -Ensure 2.1.9 support.

      Action: Investigate whether Puppet 4.7 should really be the minimum supported puppet version.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                bryan.jen Bryan Jen
                Reporter:
                bryan.jen Bryan Jen
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: