Details

    • Epic Name:
      Multi-Puppet support in the PDK
    • Template:
    • Team/s:
      Puppet Developer Experience
    • Release Notes:
      New Feature
    • Release Notes Summary:
      This is a new feature that gives users the ability to test and validate against specific Puppet or PE versions. The new options added to `pdk validate` and `pdk test unit` are `--pe-version` and `--puppet-version`.
    • QA Risk Assessment:
      Needs Assessment

      Description

      The current version of the PDK does not provide an accurate test environment for the entire set of Platform versions we want to support. Only testing against the latest puppet version is fully supported.

      • ship ruby 2.4.3
      • expose Puppet version primitive from the Gemfile on the CLI
      • Remove puppet 3 and puppet <4.7 support from the template
      • Follow Puppet6 development to be ready for GA.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  bryan.jen Bryan Jen
                  Reporter:
                  david.schmitt David Schmitt
                • Votes:
                  3 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Due:
                    Created:
                    Updated:
                    Resolved: