Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-735

tabs in .sync.yml lead to error message on `pdk convert`

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PDK 1.9.0
    • Component/s: None
    • Template:
    • Method Found:
      Needs Assessment
    • Release Notes:
      New Feature
    • Release Notes Summary:
      `pdk validate` now includes syntax validation of YAML files in the module.
    • QA Risk Assessment:
      Needs Assessment

      Description

      See CS demo: when indenting entries in .sync.yml with TABs instead of spaces, pdk convert fails to render templates.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                tim.sharpe Tim Sharpe
                Reporter:
                david.schmitt David Schmitt
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: