Uploaded image for project: 'Puppet Development Kit'
  1. Puppet Development Kit
  2. PDK-969

pdk bundle exec failing to find gem binaries on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PDK 1.5.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Template:
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Fixed packaging issue that was preventing `pdk bundle exec` from being able to run executables from gems on Windows when using Ruby 2.1.9
    • QA Risk Assessment:
      Needs Assessment

      Description

      This issue is only present on Windows and only when selecting a version of Puppet that switches to Ruby 2.1.9. When trying to run a gem binary via `pdk bundle exec`, it fails to find the gem binary with "The system cannot find the path specified". If you run a non-gem binary with `pdk bundle exec`, it runs fine (eg `pdk bundle exec ruby --version`).

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            tim.sharpe Tim Sharpe
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support